ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Audio Player Plugin <= 2.0 - Multiple XSS

Product
Audio Player
Description
Because of these vulnerabilities in the wp_ajax_save_item function, the attackers can inject arbitrary web script or HTML via the "item[name]" or "item[customcss]" parameters in a wonderplugin_audio_save_item action to wp-admin/admin-ajax.php.
Solution
Upgrade the plugin.
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
CVE Mitre
CVE
Name CVE-2015-2218
Versions
Affected In <= 2.0
Fixed In 2.1
Disclosure date
2015-03-05
Credits
Kacper Szurek