ThreatPress

WordPress Vulnerabilities Database

Back

WordPress BulletProof Security Plugin <= .51 - XSS

Product
BulletProof Security
Description
Because of this vulnerability in admin/htaccess/bpsunlock.php, the attackers can inject arbitrary web script or HTML via the "dbhost" parameter.
Solution
Update the plugin.
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
CVE Mitre
CVE
Name CVE-2014-7958
Versions
Affected In <= .51
Fixed In .51.1
Disclosure date
2014-10-07
Credits
Pietro Oliva