ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Code Snippets plugin <= 2.13.3 - Cross-Site Request Forgery (CSRF) to Remote Code Execution (RCE) vulnerability

Product
Code Snippets
Description
Cross-Site Request Forgery (CSRF) to Remote Code Execution (RCE) vulnerability found by Chloe Chamberland in WordPress Code Snippets plugin (versions <= 2.13.3).
Solution
Update the WordPress Code Snippets plugin to the latest available version (at least 2.14.0).
Classification
Type Cross Site Request Forgery (CSRF)
OWASP Top 10 A8: Cross Site Request Forgery (CSRF)
References
Plugin changelog
CVE
Name CVE-2020-8417
Versions
Affected In <= 2.13.3
Fixed In 2.14.0
Disclosure date
2020-01-29
Credits
Chloe Chamberland
Submitter
ThreatPress