ThreatPress

WordPress Vulnerabilities Database

Back

WordPress ComicPress Manager Plugin 1.4.9 - Cross-Site Scripting

Product
ComicPress Manager
Description
ComicPress Manager plugin's "lang" parameter is prone to a cross-site scripting vulnerability. It fails to properly clean up user-supplied input. An attacker may execute arbitrary script code in the browser of an user in the context of the affected site. In this way the attacker can steal cookie-based authentication credentials. Other attacks are also possible.
Solution
Update the plugin.
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
Exploit-DB
CVE
Name CVE-N/A
Versions
Affected In <= 1.4.9, 1.4.9.9, 1.4.9.2
Fixed In 1.5
Disclosure date
2011-02-23
Credits
AutoSec Tools