ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Cover WP Theme 1.6.5 - Cross Site Scripting

Product
Cover WP
Description
WordPress Cover WP theme's "s" parameter is prone to a cross-site scripting vulnerability. It fails to properly clean up user-supplied input. An attacker may execute arbitrary script code in the browser of an user in the context of the affected site. In this way the attacker can steal cookie-based authentication credentials. Other attacks are also possible.
Solution
Upgrade the theme.
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
Exploit-DB
CVE
Name CVE-2011-3860
Versions
Affected In <= 1.6.6
Fixed In 1.6.7
Disclosure date
2011-09-24
Credits
jabdah