ThreatPress

WordPress Vulnerabilities Database

Back

WordPress File Upload Plugin - SQL Injection

Product
File Upload
Description
Because of this vulnerability in wp-uploadfile.php, the attackers can execute arbitrary SQL commands via the "f_id" parameter.
Solution
Update the plugin.
Classification
Type SQL Injection
OWASP Top 10 A1: Injection
References
CVE Mitre
CVE
Name CVE-2008-2510
Versions
Affected In <= 1.0
Fixed In 1.1
Disclosure date
2008-05-29