ThreatPress

WordPress Vulnerabilities Database

Back

WordPress GRAND Flash Album Gallery Plugin 0.55 - Multiple Vulnerabilities

Product
GRAND Flash Album Gallery
Description
There are several vulnerabilities in this WordPress GRAND Flash Album Gallery plugin. First vulnerability is SQL injection that exists because of failure in the "/wp-content/plugins/flash-album-gallery/lib/hitcounter.php" script to properly sanitize user-supplied input in "pid" variable. It allows an attacker to modify data, alter queries to the application SQL database, compromise the access and application or exploit hidden vulnerabilities in the underlying database. Second vulnerability is file content disclosure that exists because of failure in the "/wp-content/plugins/flash-album-gallery/admin/news.php" script to properly clean up user-supplied input in "want2Read" variable. It allows an attacker to obtain content of arbitrary file accessible within the context of vulnerable application.
Solution
Update the plugin.
Classification
Type Multi
References
Exploit-DB
CVE
Name CVE-N/A
Versions
Affected In <= 0.55
Fixed In 0.56
Disclosure date
2011-03-08
Credits
High-Tech Bridge SA