ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Gigya Socialize Plugin 1.0/1.1.x - Cross-Site Scripting Vulnerability

Product
Gigya Socialize
Description
Gigya Socialize plugin is prone to a cross-site scripting vulnerability. It fails to properly clean up user-supplied input. An attacker may execute arbitrary script code in the browser of an user in the context of the affected site. In this way the attacker can steal cookie-based authentication credentials. Other attacks are also possible.
Solution
Update the plugin.
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
Exploit-DB
CVE
Name CVE-N/A
Versions
Affected In <= 1.1.8, 1.1.8, 1.1.7, 1.1.6, 1.1.5, 1.1.4, 1.1.3, 1.1.2, 1.1.1, 1.0
Fixed In 1.1.9
Disclosure date
2010-06-04
Credits
MustLive