ThreatPress

WordPress Vulnerability Database

Back

WordPress Name Directory plugin <= 1.17.4 - Cross-Site Request Forgery (CSRF) vulnerability

Product
Name Directory
Description
Cross-Site Request Forgery (CSRF) vulnerability found by Yuta in WordPress Name Directory plugin (versions <= 1.17.4).
Solution
Update the WordPress Name Directory plugin to the latest available version (at least 1.18).
Classification
Type Cross Site Request Forgery (CSRF)
OWASP Top 10 A8: Cross Site Request Forgery (CSRF)
References
CVE
Vulnerability details
Plugin changelog
CVE
Name CVE-2021-20652
Versions
Affected In <= 1.17.4
Fixed In 1.18
Disclosure date
2021-01-10
Credits
Yuta