ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Contact Form & SMTP by PirateForms plugin <= 1.5.1 - Cross-Site Request Forgery (CSRF) vulnerability

Product
Contact Form & SMTP Plugin
Description
Cross-Site Request Forgery (CSRF) vulnerability found by Jerome Bruandet in WordPress Contact Form & SMTP by PirateForms plugin (versions <= 1.5.1).
Solution
Update the WordPress Contact Form & SMTP by PirateForms plugin to the latest available version (at least 1.5.2).
Classification
Type Cross Site Request Forgery (CSRF)
OWASP Top 10 A8: Cross Site Request Forgery (CSRF)
References
Plugin changelog
CVE
Name CVE-N/A
Versions
Affected In <= 1.5.1
Fixed In 1.5.2
Disclosure date
2019-07-29
Credits
Jerome Bruandet
Submitter
ThreatPress