ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Regular Subscriber Plugin 3.1.x - HTML Injection Vulnerability

Product
Regular Subscriber
Description
WordPress Regular Subscriber plugin is prone to an HTML-injection vulnerability because of failure to sufficiently clean up user-supplied input. It allows an attacker to execute arbitrary script code in the browser in the context of the affected websites. In this way an attacker can steal cookie-based authentication credentials or control how the websites are rendered to the user. Other attacks (for the example a cross-site scripting) are also possible.
Solution
Update the plugin.
Classification
Type Multi
OWASP Top 10 A1: Injection
References
Exploit-DB
CVE
Name CVE-N/A
Versions
Affected In <= 3.1.9
Fixed In 3.4
Disclosure date
2011-09-26
Credits
knull