ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Silverlight Media Player Plugin <= 0.8 - XSS

Product
Silverlight Media Player
Description
Because of this vulnerability in uploader.php, the attackers can inject arbitrary web script or HTML via the "post_id" parameter.
Solution
Update the plugin.
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
CVE Mitre
CVE
Name CVE-2014-4589
Versions
Affected In <= 0.8
Fixed In 0.9
Disclosure date
2014-06-23
Credits
Prajal Kulkarni