ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Slideshow Gallery Plugin 1.1.x - Cross Site Scripting

Product
Slideshow Gallery
Description
WordPress Slideshow Gallery plugin's "border" parameter is prone to a cross-site scripting vulnerability. It fails to properly clean up user-supplied input. An attacker may execute arbitrary script code in the browser of an user in the context of the affected site. In this way the attacker can steal cookie-based authentication credentials. Other attacks are also possible.
Solution
Update the plugin.
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
Exploit-DB
CVE
Name CVE-2012-5229
Versions
Affected In <= 1.1.9
Fixed In 1.2
Disclosure date
2012-01-26
Credits
Bret Hawk