ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Cookie Consent plugin <=2.3.9 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

Product
Cookie Consent
Description
Authenticated Stored Cross-Site Scripting (XSS) vulnerability found in WordPress Cookie Consent plugin (versions <=2.3.9).
Solution
Update the WordPress Cookie Consent plugin to the latest available version (at least 2.3.10).
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
Plugin changelog
CVE
Name CVE-2018-10310
Versions
Affected In <=2.3.9
Fixed In 2.3.10
Disclosure date
2018-04-29
Credits
James Boughey
Submitter
ThreatPress