ThreatPress

WordPress Vulnerabilities Database

Back

WordPress User Photo Plugin <= 0.9.5.1 - XSS

Product
User Photo
Description
Because of this vulnerability in user-photo.php, attackers can inject arbitrary web script or HTML via the PATH_INFO to wp-admin/options-general.php.
Solution
Update the plugin.
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
CVE Mitre
CVE
Name CVE-2012-2920
Versions
Affected In <= 0.9.5.1
Fixed In 0.9.5.2
Disclosure date
2012-05-21
Credits
Ryan Hellyer