ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Widget Logic plugin <= 5.9.0 - Cross-Site Request Forgery (CSRF) vulnerability

Product
Widget Logic
Description
Cross-Site Request Forgery (CSRF) vulnerability that leads to Remote Code Execution (RCE) found by Paul Dannewitz in WordPress Widget Logic plugin (versions <= 5.9.0).
Solution
Update the WordPress Widget Logic plugin to the latest available version (at least 5.10.2).
Classification
Type Cross Site Request Forgery (CSRF)
OWASP Top 10 A8: Cross Site Request Forgery (CSRF)
References
Plugin changelog
CVE
Name CVE-2019-12826
Versions
Affected In <= 5.9.0
Fixed In 5.10.2
Disclosure date
2019-07-02
Credits
Paul Dannewitz
Submitter
ThreatPress