ThreatPress

WordPress Vulnerabilities Database

Back

WordPress WooCommerce Plugin <= 2.2.2 - XSS

Product
WooCommerce
Description
Because of this vulnerability, the attackers can inject arbitrary web script or HTML via the "range" parameter on the wc-reports page to wp-admin/admin.php.
Solution
Update the plugin.
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
CVE Mitre
CVE
Name CVE-2014-6313
Versions
Affected In <= 2.2.2
Fixed In 2.2.3
Disclosure date
2014-09-11
Credits
Tom Adams