ThreatPress

WordPress Vulnerabilities Database

Back

WordPress <=1.2 - CRLF (Carriage Return Line Feed) injection

Product
WordPress
Description
Because of this vulnerability in wp-login.php, attackers can perform HTTP Response Splitting attacks to modify expected HTML content from the server via the "text" parameter.
Solution
Update the WordPress to the latest available version (at least 1.2.1).
Classification
Type CRLF Injection
OWASP Top 10 A1: Injection
References
CVE Mitre
CVE
Name CVE-2004-1584
Versions
Affected In <=1.2
Fixed In 1.2.1
Disclosure date
2005-02-20
Credits
Chaotic Evil
Submitter
ThreatPress