ThreatPress

WordPress Vulnerabilities Database

Back

WordPress <= 1.5.2 - SQL injection

Product
WordPress
Description
Because of this vulnerability, attackers can execute arbitrary SQL commands via the User-Agent field in an HTTP header for a comment.
Solution
Update the WordPress to the latest available version (at least 1.5.3).
Classification
Type SQL Injection
OWASP Top 10 A1: Injection
References
CVE Mitre
CVE
Name CVE-2006-1012
Versions
Affected In <= 1.5.2
Fixed In 1.5.3
Disclosure date
2006-03-06
Submitter
ThreatPress