ThreatPress

WordPress Vulnerabilities Database

Back

WordPress <= 2.1.0 - XSS

Product
WordPress
Description
Because of this vulnerability, the attackers can inject arbitrary web script or HTML via the "file" parameter.
Solution
Update the WordPress to the latest available version (at least 2.1.1).
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
CVE Mitre
CVE
Name CVE-2007-1049
Versions
Affected In <= 2.1.0
Fixed In 2.1.1
Disclosure date
2007-02-21
Credits
PsychoGun
Submitter
ThreatPress