ThreatPress

WordPress Vulnerabilities Database

Back

WordPress <= 2.1.1 - Multiple XSS

Product
WordPress
Description
Because of these vulnerabilities in wp-includes/functions.php, the attackers can inject arbitrary web script or HTML.
Solution
Update the WordPress to the latest available version (at least 2.1.2).
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
CVE Mitre
CVE
Name CVE-2007-1230
Versions
Affected In <= 2.1.1
Fixed In 2.1.2
Disclosure date
2007-03-02
Credits
markjaquith
Submitter
ThreatPress