ThreatPress

WordPress Vulnerabilities Database

Back

WordPress <= 2.1.2 - SQL Injection vulnerability

Product
WordPress
Description
Because of this vulnerability in xmlrpc, the authenticated users can execute arbitrary SQL commands.
Solution
Update the WordPress to the latest available version (at least 2.1.3).
Classification
Type SQL Injection
OWASP Top 10 A1: Injection
References
CVE Mitre
CVE
Name CVE-2007-1897
Versions
Affected In <= 2.1.2
Fixed In 2.1.3
Disclosure date
2007-04-09
Credits
Sid
Submitter
ThreatPress