ThreatPress

WordPress Vulnerabilities Database

Back

WordPress WP Smiley Plugin <= 1.4.1 - CSRF

Product
WP Smiley
Description
This vulnerability allows an attacker to hijack the authentication of editors for requests that conduct cross-site scripting (XSS) attacks via the "s4w-more" parameter to the smilies4wp.php page to wp-admin/options-general.php.
Solution
Update the plugin.
Classification
Type Cross Site Request Forgery (CSRF)
OWASP Top 10 A8: Cross Site Request Forgery (CSRF)
References
CVE Mitre
CVE
Name CVE-2015-4140
Versions
Affected In <= 1.4.1
Fixed In 1.4.2
Disclosure date
2015-05-31
Credits
Henri Salo