ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Splashing Images plugin <=2.1 - Authenticated PHP Object Injection vulnerability

Product
Splashing Images
Description
Authenticated PHP Object Injection vulnerability found by Nicolas Buzy-Debat in WordPress Splashing Images plugin (versions <=2.1). PHP Object Injection attack via crafted serialized data in the 'session' HTTP GET parameter to wp-admin/upload.php.
Solution
Update the WordPress Splashing Images plugin to the latest available version (at least 2.1.1).
Classification
Type Unknown
References
Plugin changelog
CVE
Name CVE-2018-6195
Versions
Affected In <=2.1
Fixed In 2.1.1
Disclosure date
2018-01-30
Credits
Nicolas Buzy-Debat
Submitter
ThreatPress