ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Splashing Images plugin <=2.1 - Cross-Site Scripting (XSS) vulnerability

Product
Splashing Images
Description
Cross-Site Scripting (XSS) vulnerability found by Nicolas Buzy-Debat in WordPress Splashing Images plugin (versions <=2.1). Possible remote injection of arbitrary web script or HTML via the search parameter to wp-admin/upload.php.
Solution
Update the WordPress Splashing Images plugin to the latest available version (at least 2.1.1).
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
Plugin changelog
CVE
Name CVE-2018-6194
Versions
Affected In <=2.1
Fixed In 2.1.1
Disclosure date
2018-01-30
Credits
Nicolas Buzy-Debat
Submitter
ThreatPress