ThreatPress

WordPress Vulnerabilities Database

Back

WordPress YITH WooCommerce Compare plugin <=2.3.14 - Authenticated Settings Change (YITH Plugin Framework <=3.3.8) vulnerability

Product
YITH WooCommerce Compare
Description
Authenticated Settings Change (YITH Plugin Framework <=3.3.8) vulnerability found by Jerome Bruandet in WordPress YITH WooCommerce Compare plugin (versions <=2.3.14).
Solution
Update the WordPress YITH WooCommerce Compare plugin to the latest available version (at least 2.3.15).
Classification
Type Unknown
OWASP Top 10 A2: Broken Authentication and Session Management
References
Plugin changelog
CVE
Name CVE-2019-16251
Versions
Affected In <=2.3.14
Fixed In 2.3.15
Disclosure date
2019-10-31
Credits
Jerome Bruandet (Nintechnet)
Submitter
ThreatPress