ThreatPress

WordPress Vulnerabilities Database

Back

WordPress YITH WooCommerce Multi-step Checkout plugin <=1.7.4 - Authenticated Settings Change (YITH Plugin Framework <=3.3.8) vulnerability

Product
YITH WooCommerce Multi-step Checkout
Description
Authenticated Settings Change (YITH Plugin Framework <=3.3.8) vulnerability found by Jerome Bruandet in WordPress YITH WooCommerce Multi-step Checkout plugin (versions <=1.7.4).
Solution
Update the WordPress YITH WooCommerce Multi-step Checkout plugin to the latest available version (at least 1.7.5).
Classification
Type Unknown
OWASP Top 10 A2: Broken Authentication and Session Management
References
Plugin changelog
CVE
Name CVE-2019-16251
Versions
Affected In <=1.7.4
Fixed In 1.7.5
Disclosure date
2019-10-31
Credits
Jerome Bruandet (Nintechnet)
Submitter
ThreatPress