ThreatPress

WordPress Vulnerabilities Database

Back

WordPress Zingiri Web Shop Plugin <= 2.4.0 - Multiple XSS Vulnerabilities

Product
Zingiri Web Shop
Description
Zingiri Web Shop plugin is prone to multiple cross-site scripting vulnerabilities. After the malicious code posted up, Javascrip code inserted to database with "$_POST['notes']" variable. When administrator wants to see list of ordered items list, Javascript codes will come from database and start working on authenticated admin user side.
Solution
Update the plugin.
Classification
Type XSS (Cross Site Scripting)
OWASP Top 10 A3: Cross Site Scripting (XSS)
References
Exploit-DB
CVE
Name CVE-2012-6506
Versions
Affected In <= 2.4.0
Fixed In 2.4.1
Disclosure date
2012-04-26
Credits
Mehmet Ince